понеділок, 21 червня 2010 р.

Ubuntu 10.04 и PHP 5.2

Обновил один из живых серверов с Ubuntu до 10.04 — радостно обновился PHP до 5.3.
В следствие чего кучу сайтов, основанных на старом PHP (Joomla, CiviCRM и т.д.) отказались работать. Попытался поиграться с настройками PHP, но старый CiviCRM упорно отказывался дружить с новым PHP.

В итоге остановился на компромисном варианте — подключил репозиторий со старым PHP, но скомпилированным с текущими системными библиотеками. За подробностями сюда (вариант 3).

Как обычно, список не полон, некоторых пакетов не хватает. Связался с автором репозитария, ждём ответа.

Немає коментарів:

Дописати коментар